Could not load PC BIOS


Peter Wiehe <peter.wiehe2@...>
 

Hello Tianocore list,

I am trying (with Qemu) to emulate an UEFI 64bit PC that boots from a virtual CD and installs an OS on a virtual HD.

But I get always an error (See below).

I use:

- Xubuntu 18.04 LTS

-  qemu-system-x86_64: QEMU emulator version 2.11.1(Debian 1:2.11+dfsg-1ubuntu7.19)

- gcc-5 (Ubuntu 5.5.0-12ubuntu1) 5.5.0 20171010

I followed your instructions in the documentation about building and installing edk2. I tried to download OVMF repo with yum and did set both targets IA32 and x86_64.

The emulation command I enter is:*
*

*qemu-system-x86_64 -L . -drive format=raw,file=hd.img,readonly=off -cdrom os.iso -net none -bios bios.bin -m 1G*

The OS-CD-ISO is Haiku if that matters. You probably want more information, but I don't know what else I can tell you.

I get the following outpout:

*qemu-system-x86_64: warning: TCG doesn't support requested feature: CPUID.01H:ECX.vmx [bit 5]**
**qemu: could not load PC BIOS 'bios.bin'*

The first line is just a warning, so it's probably not important (I hope). But the last line is bad. I also tried without "-L .". DIdn't work either.

What can I do? Do I have to build OVMF from source? Or how precisely can I find the OVMF "BIOS" file?

Or maybe it isn't a Tianocore problem, but a Qemu bug?

Thanks for any help

Peter

Join discuss@edk2.groups.io to automatically receive all group messages.