[PATCH 11/24] CryptoPkg/BaseCryptLib: no openssl deprecation warnings please


Gerd Hoffmann
 

Stop using deprecated interfaces is left as exercise for another day.
So please don't warn for now so -Werror builds can work.

Signed-off-by: Gerd Hoffmann <kraxel@redhat.com>
---
CryptoPkg/Library/BaseCryptLib/InternalCryptLib.h | 2 ++
1 file changed, 2 insertions(+)

diff --git a/CryptoPkg/Library/BaseCryptLib/InternalCryptLib.h b/CryptoPkg/Library/BaseCryptLib/InternalCryptLib.h
index ff6d33835b2a..2165a6b5b1c2 100644
--- a/CryptoPkg/Library/BaseCryptLib/InternalCryptLib.h
+++ b/CryptoPkg/Library/BaseCryptLib/InternalCryptLib.h
@@ -20,6 +20,8 @@ SPDX-License-Identifier: BSD-2-Clause-Patent

#include "CrtLibSupport.h"

+#define OPENSSL_NO_DEPRECATED 0
+
#include <openssl/opensslv.h>

#if OPENSSL_VERSION_NUMBER < 0x10100000L
--
2.33.1