Python2.7 is not working with the EDK2 build system


Sunny Wang
 

Hi all,

 

I just ran into this build issue. After checking the edk2 emails, I saw some of you already ran into this build issue as well. At least, I saw two email threads below talking about this issue.  

https://edk2.groups.io/g/devel/message/80068?p=,,,20,0,0,0::recentpostdate%252Fsticky,,python,20,2,0,85296733

https://edk2.groups.io/g/devel/message/79022?p=,,,20,0,0,0::recentpostdate%2525252Fsticky,,DeprecationWarnings,20,2,0,84409128

 

The main purpose of this email is to have obvious email subject to get people’s attention, so that people won’t spend time to check this when running into this issue.

The solution at this moment is to use Python 3 instead (Use “export PYTHON_COMMAND=/usr/bin/python3” instead of “export PYTHON_COMMAND=/usr/bin/python”).   

 

Hi Robinson,

Are you working on this now? If you’re busy with other things, how about we revert your patch first?

 

Hi Bob, Liming, and Yuwei,

What do you prefer to do at this moment? Wait for Robinson? or revert the change?

 

Best Regards,

Sunny

IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you.

Join devel@edk2.groups.io to automatically receive all group messages.