[PATCH 07/17] IntelFspWrapperPkg DSC: Add build option to disable deprecated APIs


Wu, Hao A
 

Add the following definition in the [BuildOptions] section in package DSC
files to disable APIs that are deprecated:

[BuildOptions]
*_*_*_CC_FLAGS = -D DISABLE_NEW_DEPRECATED_INTERFACES

Cc: Jiewen Yao <jiewen.yao@intel.com>
Contributed-under: TianoCore Contribution Agreement 1.0
Signed-off-by: Hao Wu <hao.a.wu@intel.com>
---
IntelFspWrapperPkg/IntelFspWrapperPkg.dsc | 3 +++
1 file changed, 3 insertions(+)

diff --git a/IntelFspWrapperPkg/IntelFspWrapperPkg.dsc b/IntelFspWrapperPkg/IntelFspWrapperPkg.dsc
index 3714e30..c960388 100644
--- a/IntelFspWrapperPkg/IntelFspWrapperPkg.dsc
+++ b/IntelFspWrapperPkg/IntelFspWrapperPkg.dsc
@@ -83,3 +83,6 @@
gEfiMdePkgTokenSpaceGuid.PcdDebugPropertyMask|0x1f
gEfiMdePkgTokenSpaceGuid.PcdDebugPrintErrorLevel|0x80080046
gEfiMdePkgTokenSpaceGuid.PcdReportStatusCodePropertyMask|0x07
+
+[BuildOptions]
+ *_*_*_CC_FLAGS = -D DISABLE_NEW_DEPRECATED_INTERFACES
--
1.9.5.msysgit.0

Join devel@edk2.groups.io to automatically receive all group messages.