Re: [PATCH v4 0/7] BaseTools: add support for GCC5 in LTO mode


Ard Biesheuvel
 

On 29 July 2016 at 17:18, Gao, Liming <liming.gao@intel.com> wrote:
Ard:

My gcc version 5.3.0 20151204 (Ubuntu 5.3.0-3ubuntu1~14.04). I will try
GCC54.
Could you check if the issue also occurs with the 'old' GCC49, i.e.,
the version that uses LD as the linker?



Besides, for new GCC5 tool chain, could you add one brief introduction in
tools_def.txt like GCC49? And, highlight it enable LTO by default.



# GCC49 -Linux,Windows- Requires:

# GCC 4.9 targeting x86_64-linux-gnu,
aarch64-linux-gnu, or arm-linux-gnueabi

# Optional:

# Required to build platforms or ACPI tables:

# Intel(r) ACPI Compiler from

# https://acpica.org/downloads
OK

--
Ard.

Join devel@edk2.groups.io to automatically receive all group messages.